CloudSigma would like to inform you that the issue with the reachability of our compute hosts in the Riyadh DC location has been fixed.
Please accept our apologies for the inconvenience caused!
Posted Mar 20, 2026 - 17:49 UTC
Identified
CloudSigma would like to inform you that the intermittent issues with the reachability of our compute hosts in our Riyadh location are still ongoing. We have identified an issue affecting our APIs' performance,
There is no impact on running instances in the cloud, but temporarily, new VMs and drives can not be provisioned.
Posted Mar 20, 2026 - 13:59 UTC
Investigating
CloudSigma would like to inform you that currently, we are experiencing intermittent issues with the reachability of our compute hosts in our Riyadh location. No machines running on the host should be impacted, save for short periods of unreachability from our API.
Our administrators are working to resolve issues as soon as possible. Thank you for your patience and understanding.