[MNL2] Payment Issues

Incident Report for CloudSigma

Update

CloudSigma would like to inform you that we are still working on fixing the issue with saving credit cards.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 17, 2025 - 13:26 UTC

Identified

CloudSigma would like to inform you that the issue in our Manila 2 cloud has been partially mitigated and that payments are once again possible. However, there is still an ongoing issue with the ability to save payment methods or save credit cards.

We wish to assure you that our team is working towards resolving the issue.

Please accept our apologies for the inconvenience.
Posted Sep 16, 2025 - 16:02 UTC

Investigating

CloudSigma would like to inform you that there is an ongoing issue with payments in our Manila 2 cloud, failing in our WebApp.
Our team is actively working on resolving the issue.

If you are facing issues with subscriptions expiring, please contact support via the WebApp chat or at support@cloudsigma.com and they will assist you.
Posted Sep 16, 2025 - 07:08 UTC
This incident affects: Manila 2 Cloud.