[RUH] Degraded API Performance

Incident Report for CloudSigma

Resolved

This incident has been resolved.
Posted Apr 27, 2026 - 11:55 UTC

Update

CloudSigma would like to inform you that the API performance issues in the Riyadh cloud locations have now been resolved. During the incident, users may have experienced issues with WebApp going in and out of availability.

If you continue to experience any issues, please do not hesitate to report them to our support team. We apologize for any inconvenience caused.
Posted Apr 27, 2026 - 11:35 UTC

Investigating

CloudSigma would like to inform you that we are facing a performance issue with the API in the Riyadh cloud location. Users may experience issues with WebApp going in and out of availability; there is no impact to running Virtual Machines on the cloud

Our Operations Team is looking into the matter. We apologize for any inconvenience caused.
Posted Apr 27, 2026 - 09:35 UTC
This incident affected: Riyadh Cloud.