CloudSigma would like to inform you that experienced packet loss on the Riyhad cloud has subsided.
Thank you for your patience, & we apologise for any inconvenience caused. We will investigate further the cause of the network issues experienced.
Posted May 24, 2026 - 10:49 UTC
Update
CloudSigma would like to inform you that the issue affecting our WebApp has subsided. We are still observing packet loss on the cloud and are in contact with our service provider to investigate the matter further.
Thank you for your patience and understanding on the matter.
Posted May 24, 2026 - 10:30 UTC
Investigating
CloudSigma would like to inform you that we are facing issues with the Riyadh webapp being unavailable. We are investigating the cause of the issue. Virtual machines on the cloud are not reachable.
We apologize for any inconvenience caused. Our operations team is investigating the matter