Cloudsigma - Live chat issue
Incident Report for CloudSigma
Resolved
The issue with our live chat provider Zopim has been resolved. You should no longer have issues reaching us over our live chat support.

Thank you for your patience on the matter
Posted Sep 19, 2016 - 10:33 UTC
Investigating
We are experiencing issues with Live chat.
Posted Sep 19, 2016 - 10:08 UTC