[ZRH] Storage issue
Incident Report for CloudSigma
Postmortem

Following the outage suffered on 1st of August, our operations team have been working to identify the root causes for the disruption which affected your computing.

Location: ZRH

Root cause: On 1st of August part of our ssd storage cluster got frozen for about few minutes. After detailed investigation we found out that it is a bug caused by a very-long chain of snapshots. This is a hard-to-hit bug, anyway we have took the necessary steps to prevent this from happening again.

Current Lessons Learned & Action Taken: 1. The length of the problematic snapshot chain was decreased by rebasing some of the snapshots in the chain. 2. The cluster client was reconfigured on few host, where one system has managed to override the cluster setting.

Next steps: Install and enable new small service that will check and reset the core processing to the cluster one in case something change it. Add monitoring for the max snapshot chain length and do the rebases needed to maintain reasonable length.

Please accept our sincere apologies for the disruption this situation has caused. We do believe we have identified and mitigated the source of this specific issue.

CloudSigma does everything possible to minimize any inconvenience to our customers. We appreciate your patience and welcome any and all feedback.

Thank you for your understanding. Contacts: If you have any questions in regards to this email, please contact our support department via our live chat at https://zrh.cloudsigma.com/ and/or email support@cloudsigma.com

Posted Aug 08, 2016 - 13:28 UTC

Resolved
The storage issue was resolved and now everything is working as expected again.
Posted Aug 01, 2016 - 00:47 UTC
Identified
A storage problem is identified and will be resolved in few minutes. Some VMs should already be accessible.
We will keep you updated.
Posted Aug 01, 2016 - 00:46 UTC
Investigating
Currently we are experiencing partial network outage in our Zurich location. Users may have some problems accessing they Virtual Machines at that time.
Posted Aug 01, 2016 - 00:31 UTC